Layers 101

Layers are one of the most powerful tools Photoshop has to offer. Experimentation is one of the best methods of learning once the basic principles of layers and layer creation and manipulation are established. This tutorial uses a basic example to take you step-by-step through the various properties and functions of layers. This tutorial covers:

What is the purpose of a layer?

Fundamentally, a layer can be thought of as a sheet of glass and an accumulation of layers functions like glass panels stacked on top of one another. Using this metaphor, theoretically when you add something to one layer, the others are left unaffected. This allows for preciseness in what you add to which part of the project, and a great deal of control in subsequent edits.

  1. To begin, open a new document in by going to File > New or use the shortcut Command + N.
  2. Create the document with the properties:
    • Name: Layers
    • Width: 500px
    • Height: 500px
    • Resolution: 72
    • Color mode: RGB Color
    • Background color: White (notice transparent as being an option)

Layers palette

  1. To make the layers palette visible if it cannot be located as below, you can go to Window > Layers.
  2. The layers palette will appear and you will notice that there is a layer called "Background." Notice that there is a lock icon on to the right of the layer name, indicating that this layer will not perform in the same way as other layers.
  3. To unlock: Double click on the name "Background." Rename it as "Background Layer" using the dialogue box. Notice that the lock is no longer present.

Adding new layers

  1. Now we will begin with adding a new layer. This functions like adding another glass sheet to the top of the existing layers. There are three ways to add a layer:
    • Go to Layer > New > Layer or
    • Use the keyboard shortcut Shift + Command + N.
    • Click the new layer button on the bottom-right corner next to the trashcan in the layers palette.
  2. In your layer palette you should now see another layer on top of your Background Layer titled "Layer 1." The small gray and white pixels in its icon indicate that it is transparent, meaning there is nothing on this layer (like a glass sheet) whereas there is a white fill on the background layer. Also, whenever you are working with multiple layers in Photoshop, you need to be sure that you are manipulating the correct layer. The blue highlight indicates that this layer is selected.
  3. Making sure again that your Layer 1 is selected, draw a very simple shape using the brush tool. Take note of visibility. Notice that you see the black shape as opposed to the white. This is a layer hierarchy.
  4. Depending on the location of the layer in the layer palette in relation to the other layers, it will either be in front or behind the surrounding layers. In general, the layers below the layer of interest will fall behind it and the ones above will appear in front of it. In this example, we have the black line visible over the white.
  5. Now with Layer 1 selected, create a new layer, it should be called "Layer 2". On the new layer use a much larger brush with a different color and cover the black shape that you created.
  6. Notice how in your layers palette, you can see the two different shapes in the thumbnails next to the layer name. This can help you identify what is on each layer.
  7. When you have multiple layers, labeling them with appropriate titles helps to keep them organized and distinguishable. You already have the Background Layer named from when you created it, now change the names of Layer 1 and Layer 2 based on their defining characteristics or purpose. For example:
    • Layer 1, I have a black shape so I will name this layer "Black shape."
    • Layer 2, I have a blue shape, so I will name this layer "Blue shape."
  8. To change the names of layers: Layer > Layer properties or double click on the name of the layer in the layers palette and rename it in the dialogue box.
  9. Now create another layer on top of the blue shape layer and title it "Red shape." Here you are going to make yet another shape using the brush tool (again, make sure you have the correct layer selected).
  10. Another important function of layers is the ability to turn their visibility off and on. To turn visibility on and off, click on the eye icon next to the layer thumbnail in the layer palette.
  11. When the eye icon is unselected it is invisible in the project window even though this layer is on top of all other layers. To turn it back on, click the same spot once more and the eye should appear again along with your layer. Turn it back on so that you can see the red.

Layer hierarchy

  1. This would be a good time to go back to layer hierarchies. You can drag layers up and down on the layers palette to make them appear over other layers. Select the Move tool in the main toolbar on the left. Now click and hold on the thumbnail for the Black shape layer and drag it up between the Blue shape layer and the Red shape layer.
  2. There are also ways to manipulate multiple layers at one time. You can select multiple layers by holding the Command key while clicking on various layers in the layers palette. Now making sure you have the move tool chosen, select the Red shape layer and the Blue shape layer, then use the tool on your canvas and move these two layers around.
  3. If you realize early that you will need to manipulate the same layers quite often, creating groups will do the same thing as selecting multiple layers but allow you to return to the layers as a group rather than selecting each layer again.
  4. To create a group, select the layers that you wish to group by using the command: Layer > Group Layers or Command + G.
  5. Notice here that the groups have their limitations. By grouping layers together, you will be bringing them together on the layer palette as well. The layers will always move to the uppermost layer's position of the layers in the group. This means that with our image, the Black shape layer is again on the bottom.

TIP: You can also manipulate the layers individually within the group if you click on the arrow next to the group name in the layers palette and then click on the individual layer you wish to change.

Deleting layers

  1. Now, for a final step, you can delete layers you no longer want or need.
  2. To delete a layer: Right-click the layer and click Delete Layer. Click and select the layer, then click the trash icon in the bottom right of the palette, or click the layer's thumbnail and drag the entire layer to the trash icon.

You should now have a basic understanding of layers and how they work.